macOS Mojave 10.14 b1 (18A293u)

Compatible models:
MacBook (Early 2015 or newer)
MacBook Air (Mid 2012 or newer)
MacBook Pro (Mid 2012 or newer)
Mac mini (Late 2012 or newer)
iMac (Late 2012 or newer )
iMac Pro (2017)
Mac Pro (late 2013, more mid-2010 and mid-2012 models with GPU compatible with Metal recommended)

Notes:
it is preliminary and is not offered for massive installation.
Install it at your own risk. Designed for developers.
It is strongly recommended before updating to create a backup in Time Machine recommended.

WHAT,S NEW

Version 10.14 b1:

  • Release notes were unavailable when this listing was updated.

REQUIREMENTS

OS X 10.10 or later, 64-bit processor

Screenshots

Download Now From FreeMac

Leave a Reply